panorama software,virtual tour software
Alternate Text
Joined: 2009-01-24
Send Msg:
Posts: 1

Tourweaver on VMware Fusion (Mac)

I could not get my copy of Tourweaver 3.0 Pro nor 4.0 Pro to activate properly on my copy of Windows XP Pro on my Mac laptop. I am running VMware Fusion, not Parallels or Microsoft Virtual PC as my virtualization software. The Offline activation using the ARF generator did not work either. I suspect that this is because your programs activation sequence is not compatible with the way VMware Fusion creates the virtual network adapters. I have tried using both Bridged and NAT networking in the virtual machine; activation still fails.


The solution was to use a USB 3G cellular modem that I plugged into a virtual machine that was already up and running and logged in (Windows XP Pro). Windows and Tourweaver both recognized it as actual hardware, instead of a virtual network connection, and the activation worked perfectly. VMware Fusion is a popular (and arguably the best) virtualization software available for Mac. It has become very popular in North America, and since many photographers use Macs, I think that maybe Easypano should consider doing some research into why your activation sequence fails using this software, so that future versions of Tourweaver can be more seamlessly compatible.

Roger Middleton

360 and Beyond - Vancouver
T. 778.388.2867
F. 604.696.3745
Alternate Text
Joined: 2006-10-23
Send Msg:
Posts: 162
Hi I know Fusion behaves quick promptly in virtualization mode.

I am using Parallels and I never encountered a problem activating Tourweaver.

So I guess if Easypano investigates the problem, (it might help them finding the solution) they should consider the specific way Fusion works.


Alternate Text
Joined: 2008-11-08
Send Msg:
Posts: 45
Hi Roger,

Same problem, probably same configuration as yours (fusion 1.1, XP SP2) MacBook Pro 2.2, Same results.

The turnaround was found in sending a message to easypano mail support.

Genseng asked me for my MAC unique ID, and sent me two files (vip.htm & gis.htm) and where I had to place them.
It instantly worked

But I still deeply regret that there is need of turnarounds are necessary when Easypasno is recommending the use of VMWare fusion on Macintosh platform Very weird way, for client satisfaction.
Mac OS X Tiger Or Leopard - VMWare fusion 2.05